What’s Vulnerable › Vulnerabilities
CVE-2009-2906
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-10-07 · updated 2026-06-16
- Weakness: CWE-835
Description
smbd in Samba 3.0 before 3.0.37, 3.2 before 3.2.15, 3.3 before 3.3.8, and 3.4 before 3.4.2 allows remote authenticated users to cause a denial of service (infinite loop) via an unanticipated oplock break notification reply packet.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04
- Samba: before 3.0.37; from 3.2.0 before 3.2.15; from 3.3.0 before 3.3.8; 3.4.0, 3.4.1 — fixed in 3.0.37, 3.2.15, 3.3.8
How to fix
Upgrade to a fixed version: Samba 3.0.37, 3.2.15, 3.3.8. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html
- http://news.samba.org/releases/3.0.37/
- http://news.samba.org/releases/3.2.15/
- http://news.samba.org/releases/3.3.8/
- http://news.samba.org/releases/3.4.2/
- http://osvdb.org/58519
- http://samba.org/samba/security/CVE-2009-2906.html
- http://secunia.com/advisories/36893
- http://secunia.com/advisories/36918
- http://secunia.com/advisories/36937
- http://secunia.com/advisories/36953
Get alerted when CVE-2009-2906 or the next vulnerability affects your stack