What’s Vulnerable › Vulnerabilities

CVE-2009-2948

Description

mount.cifs in Samba 3.0 before 3.0.37, 3.2 before 3.2.15, 3.3 before 3.3.8 and 3.4 before 3.4.2, when mount.cifs is installed suid root, does not properly enforce permissions, which allows local users to read part of the credentials file and obtain the password by specifying the path to the credentials file and using the --verbose or -v option.

Affected products

How to fix

Upgrade to a fixed version: Samba 3.0.37, 3.2.15, 3.3.8, 3.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-2948 or the next vulnerability affects your stack