What’s Vulnerable › Vulnerabilities
CVE-2009-3094
- Severity: low (CVSS 2.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-09-08 · updated 2026-06-16
- Weakness: CWE-476
Description
The ap_proxy_ftp_handler function in modules/proxy/proxy_ftp.c in the mod_proxy_ftp module in the Apache HTTP Server 2.0.63 and 2.2.13 allows remote FTP servers to cause a denial of service (NULL pointer dereference and child process crash) via a malformed reply to an EPSV command.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.64; from 2.2.0 before 2.2.14 — fixed in 2.0.64, 2.2.14
- Debian Linux: 4.0, 5.0
- Fedoraproject Fedora: 10, 12
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.64, 2.2.14. Check the vendor advisory for mitigations.
References
- http://intevydis.com/vd-list.shtml
- http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00006.html
- http://marc.info/?l=bugtraq&m=126998684522511&w=2
- http://marc.info/?l=bugtraq&m=127557640302499&w=2
- http://marc.info/?l=bugtraq&m=133355494609819&w=2
- http://secunia.com/advisories/36549
- http://secunia.com/advisories/37152
- http://wiki.rpath.com/Advisories:rPSA-2009-0155
- http://www-01.ibm.com/support/docview.wss?uid=swg1PK96858
- http://www-01.ibm.com/support/docview.wss?uid=swg1PM09161
- http://www.debian.org/security/2009/dsa-1934
- http://www.intevydis.com/blog/?p=59
Get alerted when CVE-2009-3094 or the next vulnerability affects your stack