What’s Vulnerable › Vulnerabilities
CVE-2009-3231
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-09-17 · updated 2026-06-16
- Weakness: CWE-287
Description
The core server component in PostgreSQL 8.3 before 8.3.8 and 8.2 before 8.2.14, when using LDAP authentication with anonymous binds, allows remote attackers to bypass authentication via an empty password.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04
- Fedoraproject Fedora: 10, 11
- Opensuse: from 10.3 through 11.1
- PostgreSQL: from 8.2 before 8.2.14; from 8.3 before 8.3.8 — fixed in 8.2.14, 8.3.8
- SUSE Linux Enterprise: 10.0-sp2, 11.0
- SUSE Linux Enterprise Server: 9
How to fix
Upgrade to a fixed version: PostgreSQL 8.2.14, 8.3.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html
- http://marc.info/?l=bugtraq&m=134124585221119&w=2
- http://secunia.com/advisories/36660
- http://secunia.com/advisories/36727
- http://secunia.com/advisories/36800
- http://secunia.com/advisories/36837
- http://wiki.rpath.com/wiki/Advisories:rPSA-2010-0012
- http://www.postgresql.org/docs/8.3/static/release-8-3-8.html
- http://www.postgresql.org/support/security.html
- http://www.securityfocus.com/archive/1/509917/100/0/threaded
- http://www.securityfocus.com/bid/36314
Get alerted when CVE-2009-3231 or the next vulnerability affects your stack