What’s Vulnerable › Vulnerabilities

CVE-2009-3294

Description

The popen API function in TSRM/tsrm_win32.c in PHP before 5.2.11 and 5.3.x before 5.3.1, when running on certain Windows operating systems, allows context-dependent attackers to cause a denial of service (crash) via a crafted (1) "e" or (2) "er" string in the second argument (aka mode), possibly related to the _fdopen function in the Microsoft C runtime library. NOTE: this might not cross privilege boundaries except in rare cases in which the mode argument is accessible to an attacker outside of an application that uses the popen function.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.2.11, 5.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-3294 or the next vulnerability affects your stack