What’s Vulnerable › Vulnerabilities

CVE-2009-3459: Adobe Acrobat and Reader Heap-Based Buffer Overflow Vulnerability

Description

Heap-based buffer overflow in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 allows remote attackers to execute arbitrary code via a crafted PDF file that triggers memory corruption, as exploited in the wild in October 2009. NOTE: some of these details are obtained from third party information.

Affected products

How to fix

Upgrade to a fixed version: Adobe Acrobat for Edge 7.1.4, 8.1.7, 9.2; Adobe Acrobat Reader 7.1.4, 8.1.7, 9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-3459 or the next vulnerability affects your stack