What’s Vulnerable › Vulnerabilities
CVE-2009-3553
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-11-20 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in the abstract file-descriptor handling interface in the cupsdDoSelect function in scheduler/select.c in the scheduler in cupsd in CUPS 1.3.7 and 1.3.10 allows remote attackers to cause a denial of service (daemon crash or hang) via a client disconnection during listing of a large number of print jobs, related to improperly maintaining a reference count. NOTE: some of these details are obtained from third party information.
Affected products
- cups: 1.3.7, 1.3.10
- macOS: before 10.5.8; from 10.6.0 before 10.6.2 — fixed in 10.5.8, 10.6.2
- Apple Mac Os X Server: before 10.5.8; from 10.6.0 before 10.6.2 — fixed in 10.5.8, 10.6.2
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04, 9.10
- Debian Linux: 5.0
- Fedoraproject Fedora: 10
- Red Hat Enterprise Linux: 5.0
How to fix
Upgrade to a fixed version: macOS 10.5.8, 10.6.2; Apple Mac Os X Server 10.5.8, 10.6.2. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2010/Jan/msg00000.html
- http://secunia.com/advisories/37360
- http://secunia.com/advisories/37364
- http://secunia.com/advisories/38241
- http://secunia.com/advisories/43521
- http://security.gentoo.org/glsa/glsa-201207-10.xml
- http://sunsolve.sun.com/search/document.do?assetkey=1-66-275230-1
- http://support.apple.com/kb/HT4004
- http://www.cups.org/newsgroups.php/newsgroups.php?v5994+gcups.bugs
- http://www.cups.org/newsgroups.php/newsgroups.php?v5996+gcups.bugs
- http://www.cups.org/newsgroups.php/newsgroups.php?v6055+gcups.bugs
- http://www.cups.org/str.php?L3200
Get alerted when CVE-2009-3553 or the next vulnerability affects your stack