What’s Vulnerable › Vulnerabilities
CVE-2009-3720
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-11-03 · updated 2026-07-20
Description
The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.64; from 2.2.0 before 2.2.17 — fixed in 2.0.64, 2.2.17
- libexpat project libexpat: 2.0.1
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.64, 2.2.17. Check the vendor advisory for mitigations.
References
- http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmltok_impl.c?r1=1.13&r2=1.15&view=patch
- http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmltok_impl.c?view=log
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051228.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051247.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051367.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051405.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051442.html
- http://lists.opensuse.org/opensuse-security-announce/2009-11/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html
Get alerted when CVE-2009-3720 or the next vulnerability affects your stack