What’s Vulnerable › Vulnerabilities
CVE-2009-3725
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-11-06 · updated 2026-06-16
- Weakness: CWE-264
Description
The connector layer in the Linux kernel before 2.6.31.5 does not require the CAP_SYS_ADMIN capability for certain interaction with the (1) uvesafb, (2) pohmelfs, (3) dst, or (4) dm subsystem, which allows local users to bypass intended access restrictions and gain privileges via calls to functions in these subsystems.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04, 9.10
- Linux kernel: before 2.6.31.5 — fixed in 2.6.31.5
How to fix
Upgrade to a fixed version: Linux kernel 2.6.31.5. Check the vendor advisory for mitigations.
References
- http://marc.info/?l=linux-kernel&m=125449888416314&w=2
- http://marc.info/?l=oss-security&m=125715484511380&w=2
- http://marc.info/?l=oss-security&m=125716192622235&w=2
- http://patchwork.kernel.org/patch/51382/
- http://patchwork.kernel.org/patch/51383/
- http://patchwork.kernel.org/patch/51384/
- http://patchwork.kernel.org/patch/51387/
- http://secunia.com/advisories/37113
- http://secunia.com/advisories/38905
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.31.5
- http://www.securityfocus.com/bid/36834
- http://www.ubuntu.com/usn/usn-864-1
Get alerted when CVE-2009-3725 or the next vulnerability affects your stack