What’s Vulnerable › Vulnerabilities

CVE-2009-3953: Adobe Acrobat and Reader Universal 3D Remote Code Execution Vulnerability

Description

The U3D implementation in Adobe Reader and Acrobat 9.x before 9.3, 8.x before 8.2 on Windows and Mac OS X, and 7.x before 7.1.4 allows remote attackers to execute arbitrary code via malformed U3D data in a PDF document, related to a CLODProgressiveMeshDeclaration "array boundary issue," a different vulnerability than CVE-2009-2994.

Affected products

How to fix

Upgrade to a fixed version: Adobe Acrobat for Edge 7.1.4, 8.2, 9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-3953 or the next vulnerability affects your stack