What’s Vulnerable › Vulnerabilities
CVE-2009-4013
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-02-02 · updated 2026-06-16
- Weakness: CWE-22
Description
Multiple directory traversal vulnerabilities in Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allow remote attackers to overwrite arbitrary files or obtain sensitive information via vectors involving (1) control field names, (2) control field values, and (3) control files of patch systems.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04, 9.10
- Debian Linux: 4.0, 5.0
- Debian Lintian: from 1.23.0 through 1.23.28; from 1.24.0 through 1.24.2.1; from 2.0.0 before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: Debian Lintian 2.3.2. Check the vendor advisory for mitigations.
References
- http://git.debian.org/?p=lintian/lintian.git%3Ba=commit%3Bh=c8d01f062b3e5137cf65196760b079a855c75e00
- http://git.debian.org/?p=lintian/lintian.git%3Ba=commit%3Bh=fbe0c92b2ef7e360d13414bf40d6af5507d0c86d
- http://packages.debian.org/changelogs/pool/main/l/lintian/lintian_2.3.2/changelog
- http://packages.qa.debian.org/l/lintian/news/20100128T015554Z.html
- http://secunia.com/advisories/38375
- http://secunia.com/advisories/38379
- http://www.debian.org/security/2010/dsa-1979
- http://www.securityfocus.com/bid/37975
- http://www.ubuntu.com/usn/USN-891-1
- http://git.debian.org/?p=lintian/lintian.git%3Ba=commit%3Bh=c8d01f062b3e5137cf65196760b079a855c75e00
- http://git.debian.org/?p=lintian/lintian.git%3Ba=commit%3Bh=fbe0c92b2ef7e360d13414bf40d6af5507d0c86d
- http://packages.debian.org/changelogs/pool/main/l/lintian/lintian_2.3.2/changelog
Get alerted when CVE-2009-4013 or the next vulnerability affects your stack