What’s Vulnerable › Vulnerabilities
CVE-2009-4110
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-11-29 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the search functionality in DotNetNuke 4.8 through 5.1.4 allows remote attackers to inject arbitrary web script or HTML via search terms that are not properly filtered before display in a custom results page.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: 4.8.0, 4.8.1, 4.8.2, 4.8.3, 4.8.4, 4.9 (+8)
References
- http://osvdb.org/60519
- http://secunia.com/advisories/37480
- http://www.dotnetnuke.com/News/SecurityPolicy/securitybulletinno31/tabid/1450/Default.aspx
- http://www.securityfocus.com/bid/37139
- https://exchange.xforce.ibmcloud.com/vulnerabilities/54453
- http://osvdb.org/60519
- http://secunia.com/advisories/37480
- http://www.dotnetnuke.com/News/SecurityPolicy/securitybulletinno31/tabid/1450/Default.aspx
- http://www.securityfocus.com/bid/37139
- https://exchange.xforce.ibmcloud.com/vulnerabilities/54453
Get alerted when CVE-2009-4110 or the next vulnerability affects your stack