What’s Vulnerable › Vulnerabilities
CVE-2009-4123
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-12 · updated 2026-06-16
- Weakness: CWE-295
Description
The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.
Affected products
- jruby-openssl: before 0.6 — fixed in 0.6
How to fix
Upgrade to a fixed version: jruby-openssl 0.6. Check the vendor advisory for mitigations.
References
- http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl
- https://github.com/advisories/GHSA-xgv7-pqqh-h2w9
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jruby-openssl/CVE-2009-4123.yml
- https://web.archive.org/web/20101213091125/http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl
- http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl
- https://github.com/advisories/GHSA-xgv7-pqqh-h2w9
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jruby-openssl/CVE-2009-4123.yml
- https://web.archive.org/web/20101213091125/http://jruby.org/2009/12/07/vulnerability-in-jruby-openssl
Get alerted when CVE-2009-4123 or the next vulnerability affects your stack