What’s Vulnerable › Vulnerabilities
CVE-2009-4324: Adobe Acrobat and Reader Use-After-Free Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-06-08
- EPSS: 81.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-12-15 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in the Doc.media.newPlayer method in Multimedia.api in Adobe Reader and Acrobat 9.x before 9.3, and 8.x before 8.2 on Windows and Mac OS X, allows remote attackers to execute arbitrary code via a crafted PDF file using ZLib compressed streams, as exploited in the wild in December 2009.
Affected products
- Adobe Acrobat for Edge: from 8.0 before 8.2; from 9.0 before 9.3 — fixed in 8.2, 9.3
- Adobe Acrobat Reader: from 8.0 before 8.2; from 9.0 before 9.3 — fixed in 8.2, 9.3
- Opensuse: 11.1, 11.2
- SUSE Linux Enterprise: 10.0-sp2, 10.0-sp3
- SUSE Linux Enterprise Debuginfo: 11
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 8.2, 9.3; Adobe Acrobat Reader 8.2, 9.3. Check the vendor advisory for mitigations.
References
- http://blogs.adobe.com/psirt/2009/12/new_adobe_reader_and_acrobat_v.html
- http://contagiodump.blogspot.com/2009/12/virustotal-httpwww.html
- http://lists.opensuse.org/opensuse-security-announce/2010-01/msg00009.html
- http://osvdb.org/60980
- http://secunia.com/advisories/37690
- http://secunia.com/advisories/38138
- http://secunia.com/advisories/38215
- http://www.adobe.com/support/security/advisories/apsa09-07.html
- http://www.adobe.com/support/security/bulletins/apsb10-02.html
- http://www.kb.cert.org/vuls/id/508357
- http://www.metasploit.com/redmine/projects/framework/repository/revisions/7881/entry/modules/exploits/windows/fileformat/adobe_media_newplayer.rb
- http://www.redhat.com/support/errata/RHSA-2010-0060.html
Get alerted when CVE-2009-4324 or the next vulnerability affects your stack