What’s Vulnerable › Vulnerabilities
CVE-2010-0127
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-05-13 · updated 2026-06-16
- Weakness: CWE-787
Description
Adobe Shockwave Player before 11.5.7.609 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted FFFFFF45h Shockwave 3D blocks in a Shockwave file.
Affected products
- Adobe Shockwave Player: before 11.5.7.609 — fixed in 11.5.7.609
How to fix
Upgrade to a fixed version: Adobe Shockwave Player 11.5.7.609. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/38751
- http://secunia.com/secunia_research/2010-17/
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511260/100/0/threaded
- http://www.vupen.com/english/advisories/2010/1128
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7477
- http://secunia.com/advisories/38751
- http://secunia.com/secunia_research/2010-17/
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511260/100/0/threaded
- http://www.vupen.com/english/advisories/2010/1128
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7477
Get alerted when CVE-2010-0127 or the next vulnerability affects your stack