What’s Vulnerable › Vulnerabilities
CVE-2010-0129
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-05-13 · updated 2026-06-16
- Weakness: CWE-190
Description
Multiple integer overflows in Adobe Shockwave Player before 11.5.7.609 allow remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted .dir (aka Director) file that triggers an array index error.
Affected products
- Adobe Shockwave Player: before 11.5.7.609 — fixed in 11.5.7.609
How to fix
Upgrade to a fixed version: Adobe Shockwave Player 11.5.7.609. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/fulldisclosure/2010-05/0138.html
- http://hi.baidu.com/fs_fx/blog/item/fa74a61705b5e24621a4e951.html
- http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=869
- http://secunia.com/advisories/38751
- http://secunia.com/secunia_research/2010-20/
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511256/100/0/threaded
- http://www.securityfocus.com/archive/1/511262/100/0/threaded
- http://www.securityfocus.com/bid/40082
- http://www.vupen.com/english/advisories/2010/1128
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7134
- http://archives.neohapsis.com/archives/fulldisclosure/2010-05/0138.html
Get alerted when CVE-2010-0129 or the next vulnerability affects your stack