What’s Vulnerable › Vulnerabilities
CVE-2010-0130
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-05-13 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in Adobe Shockwave Player before 11.5.7.609 might allow remote attackers to execute arbitrary code via a crafted .dir (aka Director) file.
Affected products
- Adobe Shockwave Player: before 11.5.7.609 — fixed in 11.5.7.609
How to fix
Upgrade to a fixed version: Adobe Shockwave Player 11.5.7.609. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/38751
- http://secunia.com/secunia_research/2010-22/
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511263/100/0/threaded
- http://www.securityfocus.com/bid/40084
- http://www.vupen.com/english/advisories/2010/1128
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7108
- http://secunia.com/advisories/38751
- http://secunia.com/secunia_research/2010-22/
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511263/100/0/threaded
- http://www.securityfocus.com/bid/40084
Get alerted when CVE-2010-0130 or the next vulnerability affects your stack