What’s Vulnerable › Vulnerabilities

CVE-2010-0302

Description

Use-after-free vulnerability in the abstract file-descriptor handling interface in the cupsdDoSelect function in scheduler/select.c in the scheduler in cupsd in CUPS before 1.4.4, when kqueue or epoll is used, allows remote attackers to cause a denial of service (daemon crash or hang) via a client disconnection during listing of a large number of print jobs, related to improperly maintaining a reference count. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-3553.

Affected products

How to fix

Upgrade to a fixed version: cups 1.4.4; macOS 10.5.8, 10.6.4; Apple Mac Os X Server 10.5.8, 10.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-0302 or the next vulnerability affects your stack