What’s Vulnerable › Vulnerabilities
CVE-2010-0307
- Severity: medium (CVSS 4.7 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-02-17 · updated 2026-06-16
Description
The load_elf_binary function in fs/binfmt_elf.c in the Linux kernel before 2.6.32.8 on the x86_64 platform does not ensure that the ELF interpreter is available before a call to the SET_PERSONALITY macro, which allows local users to cause a denial of service (system crash) via a 32-bit application that attempts to execute a 64-bit application and then triggers a segmentation fault, as demonstrated by amd64_killer, related to the flush_old_exec function.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04, 9.10
- Debian Linux: 4.0, 5.0
- Linux kernel: before 2.6.32.8 — fixed in 2.6.32.8
How to fix
Upgrade to a fixed version: Linux kernel 2.6.32.8. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=221af7f87b97431e3ee21ce4b0e77d5411cf1549
- http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035159.html
- http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00000.html
- http://marc.info/?l=linux-mm&m=126466407724382&w=2
- http://marc.info/?t=126466700200002&r=1&w=2
- http://secunia.com/advisories/38492
- http://secunia.com/advisories/38779
- http://secunia.com/advisories/38922
- http://secunia.com/advisories/39649
- http://secunia.com/advisories/43315
- http://support.avaya.com/css/P8/documents/100088287
- http://www.debian.org/security/2010/dsa-1996
Get alerted when CVE-2010-0307 or the next vulnerability affects your stack