What’s Vulnerable › Vulnerabilities
CVE-2010-0395
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-06-10 · updated 2026-06-16
Description
OpenOffice.org 2.x and 3.0 before 3.2.1 allows user-assisted remote attackers to bypass Python macro security restrictions and execute arbitrary Python code via a crafted OpenDocument Text (ODT) file that triggers code execution when the macro directory structure is previewed.
Affected products
- Apache Software Foundation Apache OpenOffice: from 2.0.0 before 3.2.1 — fixed in 3.2.1
- Canonical Ubuntu Linux: 8.04, 9.04, 9.10, 10.04
- Debian Linux: 5.0, 6.0
- Fedoraproject Fedora: 11, 12, 13
- Opensuse: 11.0, 11.1, 11.2
- SUSE Linux Enterprise Server 15 SP1: 10-sp3, 11
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OpenOffice 3.2.1. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/042468.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/042529.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/042534.html
- http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html
- http://secunia.com/advisories/40070
- http://secunia.com/advisories/40084
- http://secunia.com/advisories/40104
- http://secunia.com/advisories/40107
- http://secunia.com/advisories/41818
- http://secunia.com/advisories/60799
- http://ubuntu.com/usn/usn-949-1
- http://www.debian.org/security/2010/dsa-2055
Get alerted when CVE-2010-0395 or the next vulnerability affects your stack