What’s Vulnerable › Vulnerabilities
CVE-2010-0410
- Severity: medium (CVSS 4.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-02-22 · updated 2026-06-16
- Weakness: CWE-399
Description
drivers/connector/connector.c in the Linux kernel before 2.6.32.8 allows local users to cause a denial of service (memory consumption and system crash) by sending the kernel many NETLINK_CONNECTOR messages.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04, 9.10
- Debian Linux: 4.0, 5.0
- Linux kernel: before 2.6.32.8 — fixed in 2.6.32.8
How to fix
Upgrade to a fixed version: Linux kernel 2.6.32.8. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=f98bfbd78c37c5946cc53089da32a5f741efdeb7
- http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035070.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-February/035159.html
- http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00007.html
- http://secunia.com/advisories/38492
- http://secunia.com/advisories/38557
- http://secunia.com/advisories/38779
- http://secunia.com/advisories/38922
- http://secunia.com/advisories/39033
- http://secunia.com/advisories/39649
Get alerted when CVE-2010-0410 or the next vulnerability affects your stack