What’s Vulnerable › Vulnerabilities

CVE-2010-0425

Description

modules/arch/win32/mod_isapi.c in mod_isapi in the Apache HTTP Server 2.0.37 through 2.0.63, 2.2.0 through 2.2.14, and 2.3.x before 2.3.7, when running on Windows, does not ensure that request processing is complete before calling isapi_unload for an ISAPI .dll module, which allows remote attackers to execute arbitrary code via unspecified vectors related to a crafted request, a reset packet, and "orphaned callback pointers."

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.0.64, 2.2.15, 2.3.7; Broadcom Vmware Ace Management Server 2.7.2; IBM WebSphere Application Server 6.1.0.31. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-0425 or the next vulnerability affects your stack