What’s Vulnerable › Vulnerabilities
CVE-2010-0440
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-02-03 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in +CSCOT+/translation in Cisco Secure Desktop 3.4.2048, and other versions before 3.5; as used in Cisco ASA appliance before 8.2(1), 8.1(2.7), and 8.0(5); allows remote attackers to inject arbitrary web script or HTML via a crafted POST parameter, which is not properly handled by an eval statement in binary/mainv.js that writes to start.html.
Affected products
- Cisco ASA Software: from 8.1 before 8.1\(2.7\); from 8.0 before 8.0\(5\); from 8.2 before 8.2\(1\) — fixed in 8.0\(5\), 8.1\(2.7\), 8.2\(1\)
- Cisco Secure Desktop: before 3.5 — fixed in 3.5
How to fix
Upgrade to a fixed version: Cisco ASA Software 8.0\(5\), 8.1\(2.7\), 8.2\(1\); Cisco Secure Desktop 3.5. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/38397
- http://tools.cisco.com/security/center/viewAlert.x?alertId=19843
- http://www.coresecurity.com/content/cisco-secure-desktop-xss
- http://www.securityfocus.com/archive/1/509290/100/0/threaded
- http://www.securityfocus.com/bid/37960
- http://www.vupen.com/english/advisories/2010/0273
- http://secunia.com/advisories/38397
- http://tools.cisco.com/security/center/viewAlert.x?alertId=19843
- http://www.coresecurity.com/content/cisco-secure-desktop-xss
- http://www.securityfocus.com/archive/1/509290/100/0/threaded
- http://www.securityfocus.com/bid/37960
- http://www.vupen.com/english/advisories/2010/0273
Get alerted when CVE-2010-0440 or the next vulnerability affects your stack