What’s Vulnerable › Vulnerabilities
CVE-2010-0442
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-02-02 · updated 2026-06-16
- Weakness: CWE-189
Description
The bitsubstr function in backend/utils/adt/varbit.c in PostgreSQL 8.0.23, 8.1.11, and 8.3.8 allows remote authenticated users to cause a denial of service (daemon crash) or have unspecified other impact via vectors involving a negative integer in the third argument, as demonstrated by a SELECT statement that contains a call to the substring function for a bit string, related to an "overflow."
Affected products
- PostgreSQL: from 7.4 before 7.4.28; from 8.0 before 8.0.24; from 8.1 before 8.1.20; from 8.2 before 8.2.16; from 8.3 before 8.3.10; from 8.4 before 8.4.3 — fixed in 7.4.28, 8.0.24, 8.1.20, 8.2.16, 8.3.10, 8.4.3
How to fix
Upgrade to a fixed version: PostgreSQL 7.4.28, 8.0.24, 8.1.20, 8.2.16. Check the vendor advisory for mitigations.
References
- http://archives.postgresql.org/pgsql-committers/2010-01/msg00125.php
- http://archives.postgresql.org/pgsql-hackers/2010-01/msg00634.php
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=567058
- http://git.postgresql.org/gitweb?p=postgresql.git%3Ba=commit%3Bh=75dea10196c31d98d98c0bafeeb576ae99c09b12
- http://git.postgresql.org/gitweb?p=postgresql.git%3Ba=commit%3Bh=b15087cb39ca9e4bde3c8920fcee3741045d2b83
- http://intevydis.blogspot.com/2010/01/postgresql-8023-bitsubstr-overflow.html
- http://secunia.com/advisories/39566
- http://secunia.com/advisories/39820
- http://secunia.com/advisories/39939
- http://securitytracker.com/id?1023510
- http://ubuntu.com/usn/usn-933-1
- http://www.debian.org/security/2010/dsa-2051
Get alerted when CVE-2010-0442 or the next vulnerability affects your stack