What’s Vulnerable › Vulnerabilities
CVE-2010-10013: AjaXplorer < 2.6 checkInstall.php Unauthenticated RCE
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-08 · updated 2026-06-16
- Weakness: CWE-78
Description
An unauthenticated remote command execution vulnerability exists in AjaXplorer (now known as Pydio Cells) versions prior to 2.6. The flaw resides in the checkInstall.php script within the access.ssh plugin, which fails to properly sanitize user-supplied input to the destServer GET parameter. By injecting shell metacharacters, remote attackers can execute arbitrary system commands on the server with the privileges of the web server process.
Affected products
- AjaXplorer: before 2.6 — fixed in 2.6
How to fix
Upgrade to a fixed version: AjaXplorer 2.6. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/multi/http/ajaxplorer_checkinstall_exec.rb
- https://sourceforge.net/projects/ajaxplorer/
- https://www.exploit-db.com/exploits/21993
- https://www.tenable.com/plugins/nessus/45489
- https://www.vulncheck.com/advisories/ajaxplorer-unauth-rce
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/multi/http/ajaxplorer_checkinstall_exec.rb
- https://www.exploit-db.com/exploits/21993
Get alerted when CVE-2010-10013 or the next vulnerability affects your stack