What’s Vulnerable › Vulnerabilities

CVE-2010-1205

Description

Buffer overflow in pngpread.c in libpng before 1.2.44 and 1.4.x before 1.4.3, as used in progressive applications, might allow remote attackers to execute arbitrary code via a PNG image that triggers an additional data row.

Affected products

How to fix

Upgrade to a fixed version: Apple iTunes for Windows 10.2; macOS 10.6.4; Apple Mac Os X Server 10.6.4; Apple Safari 5.0.4; Google Chrome 5.0.375.99; pnggroup libpng 1.2.44, 1.4.3; Mozilla Firefox 3.5.11, 3.6.7; Mozilla Seamonkey 2.0.6; Mozilla Thunderbird 3.0.6, 3.1.1; VMware Player 2.5.5, 3.1.2; VMware Workstation 6.5.5, 7.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-1205 or the next vulnerability affects your stack