What’s Vulnerable › Vulnerabilities
CVE-2010-1280
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-05-13 · updated 2026-06-16
- Weakness: CWE-787
Description
Adobe Shockwave Player before 11.5.7.609 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted .dir (aka Director) file, related to (1) an erroneous dereference and (2) a certain Shock.dir file.
Affected products
- Adobe Shockwave Player: before 11.5.7.609 — fixed in 11.5.7.609
How to fix
Upgrade to a fixed version: Adobe Shockwave Player 11.5.7.609. Check the vendor advisory for mitigations.
References
- http://archives.neohapsis.com/archives/fulldisclosure/2010-05/0139.html
- http://secunia.com/advisories/38751
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511257/100/0/threaded
- http://www.vupen.com/english/advisories/2010/1128
- http://www.zeroscience.mk/codes/shockwave_mem.txt
- http://www.zeroscience.mk/en/vulnerabilities/ZSL-2010-4937.php
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7184
- http://archives.neohapsis.com/archives/fulldisclosure/2010-05/0139.html
- http://secunia.com/advisories/38751
- http://www.adobe.com/support/security/bulletins/apsb10-12.html
- http://www.securityfocus.com/archive/1/511257/100/0/threaded
Get alerted when CVE-2010-1280 or the next vulnerability affects your stack