What’s Vulnerable › Vulnerabilities

CVE-2010-1297: Adobe Flash Player Memory Corruption Vulnerability

Description

Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64; Adobe AIR before 2.0.2.12610; and Adobe Reader and Acrobat 9.x before 9.3.3, and 8.x before 8.2.3 on Windows and Mac OS X, allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted SWF content, related to authplay.dll and the ActionScript Virtual Machine 2 (AVM2) newfunction instruction, as exploited in the wild in June 2010.

Affected products

How to fix

Upgrade to a fixed version: Adobe Acrobat for Edge 8.2.3, 9.3.3; Adobe Air 2.0.2.12610; Adobe Flash Player 24.0.0.186 and earlier. 10.1.53.64, 9.0.277.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-1297 or the next vulnerability affects your stack