What’s Vulnerable › Vulnerabilities
CVE-2010-1321
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-05-19 · updated 2026-06-16
- Weakness: CWE-476
Description
The kg_accept_krb5 function in krb5/accept_sec_context.c in the GSS-API library in MIT Kerberos 5 (aka krb5) through 1.7.1 and 1.8 before 1.8.2, as used in kadmind and other applications, does not properly check for invalid GSS-API tokens, which allows remote authenticated users to cause a denial of service (NULL pointer dereference and daemon crash) via an AP-REQ message in which the authenticator's checksum field is missing.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04
- Debian Linux: 5.0, 6.0
- Fedoraproject Fedora: 11, 12, 13
- MIT Kerberos 5: through 1.7.1; from 1.8 before 1.8.2 — fixed in 1.8.2
- Opensuse: 11.0, 11.1, 11.2, 11.3
- Oracle Database: all versions
- SUSE Linux Enterprise Server: 10-sp3, 11, 11-sp1
How to fix
Upgrade to a fixed version: MIT Kerberos 5 1.8.2. Check the vendor advisory for mitigations.
References
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02257427
- http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041615.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041645.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041654.html
- http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2012-01/msg00010.html
- http://marc.info/?l=bugtraq&m=134254866602253&w=2
- http://osvdb.org/64744
- http://secunia.com/advisories/39762
Get alerted when CVE-2010-1321 or the next vulnerability affects your stack