What’s Vulnerable › Vulnerabilities
CVE-2010-1637
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-06-22 · updated 2026-06-16
- Weakness: CWE-918
Description
The Mail Fetch plugin in SquirrelMail 1.4.20 and earlier allows remote authenticated users to bypass firewall restrictions and use SquirrelMail as a proxy to scan internal networks via a modified POP3 port number.
Affected products
- macOS: before 10.6.8 — fixed in 10.6.8
- Apple Mac Os X Server: before 10.6.8 — fixed in 10.6.8
- Fedoraproject Fedora: 11, 12, 13
- RedHat Enterprise Linux Desktop: 5.0
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Workstation: 5.0
- SquirrelMail: through 1.4.20
How to fix
Upgrade to a fixed version: macOS 10.6.8; Apple Mac Os X Server 10.6.8. Check the vendor advisory for mitigations.
References
- http://conference.hitb.org/hitbsecconf2010dxb/materials/D1%20-%20Laurent%20Oudot%20-%20Improving%20the%20Stealthiness%20of%20Web%20Hacking.pdf#page=69
- http://lists.apple.com/archives/security-announce/2012/Feb/msg00000.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/043239.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/043258.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/043261.html
- http://rhn.redhat.com/errata/RHSA-2012-0103.html
- http://secunia.com/advisories/40307
- http://squirrelmail.org/security/issue/2010-06-21
- http://squirrelmail.svn.sourceforge.net/viewvc/squirrelmail/branches/SM-1_4-STABLE/squirrelmail/plugins/mail_fetch/functions.php?r1=13951&r2=13950&pathrev=13951
- http://squirrelmail.svn.sourceforge.net/viewvc/squirrelmail/branches/SM-1_4-STABLE/squirrelmail/plugins/mail_fetch/options.php?r1=13951&r2=13950&pathrev=13951
- http://support.apple.com/kb/HT5130
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:120
Get alerted when CVE-2010-1637 or the next vulnerability affects your stack