What’s Vulnerable › Vulnerabilities
CVE-2010-1772
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-09-24 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in page/Geolocation.cpp in WebCore in WebKit before r59859, as used in Google Chrome before 5.0.375.70, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted web site, related to failure to stop timers associated with geolocation upon deletion of a document.
Affected products
- Canonical Ubuntu Linux: 9.10, 10.04, 10.10
- Fedoraproject Fedora: 12, 13
- Google Chrome: before 5.0.375.70 — fixed in 5.0.375.70
- Opensuse: 11.2, 11.3
- Red Hat Enterprise Linux: 6.0
How to fix
Upgrade to a fixed version: Google Chrome 5.0.375.70. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=44868
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-July/044023.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-July/044031.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
- http://secunia.com/advisories/40557
- http://secunia.com/advisories/41856
- http://secunia.com/advisories/43068
- http://trac.webkit.org/changeset/59859
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:039
- http://www.ubuntu.com/usn/USN-1006-1
Get alerted when CVE-2010-1772 or the next vulnerability affects your stack