What’s Vulnerable › Vulnerabilities
CVE-2010-1815
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-09-09 · updated 2026-06-16
- Weakness: CWE-399
Description
Use-after-free vulnerability in WebKit in Apple iOS before 4.1 on the iPhone and iPod touch, and webkitgtk before 1.2.6, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via vectors involving scrollbars.
Affected products
- Apple Iphone Os: before 4.1 — fixed in 4.1
- Canonical Ubuntu Linux: 9.10, 10.04, 10.10
- Webkit: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: Apple Iphone Os 4.1; Webkit 1.2.6. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2010//Nov/msg00002.html
- http://lists.apple.com/archives/security-announce/2010//Nov/msg00003.html
- http://lists.apple.com/archives/security-announce/2010//Sep/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/41856
- http://secunia.com/advisories/42314
- http://secunia.com/advisories/43068
- http://secunia.com/advisories/43086
- http://support.apple.com/kb/HT4334
- http://support.apple.com/kb/HT4455
- http://support.apple.com/kb/HT4456
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:039
Get alerted when CVE-2010-1815 or the next vulnerability affects your stack