What’s Vulnerable › Vulnerabilities

CVE-2010-1822

Description

WebKit, as used in Apple Safari before 4.1.3 and 5.0.x before 5.0.3 and Google Chrome before 6.0.472.62, does not properly perform a cast of an unspecified variable, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via an SVG element in a non-SVG document.

Affected products

How to fix

Upgrade to a fixed version: Apple Safari 4.1.3, 5.0.3; Google Chrome 6.0.472.62. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-1822 or the next vulnerability affects your stack