What’s Vulnerable › Vulnerabilities
CVE-2010-20010: Foxit PDF Reader < 4.2.0.0928 Title Stack Buffer Overflow
- Severity: high (CVSS 8.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-20 · updated 2026-06-16
- Weakness: CWE-121
Description
Foxit PDF Reader before 4.2.0.0928 does not properly bound-check the /Title entry in the PDF Info dictionary. A specially crafted PDF with an overlong Title string can overflow a fixed-size stack buffer, corrupt the Structured Exception Handler (SEH) chain, and lead to arbitrary code execution in the context of the user who opens the file.
Affected products
- Foxit Software Foxit PDF Reader: before 4.2.0.0928 — fixed in 4.2.0.0928
How to fix
Upgrade to a fixed version: Foxit Software Foxit PDF Reader 4.2.0.0928. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/windows/fileformat/foxit_title_bof.rb
- https://www.exploit-db.com/exploits/15514/
- https://www.exploit-db.com/exploits/15532
- https://www.exploit-db.com/exploits/16621
- https://www.foxit.com/pdf-reader/version-history.html
- https://www.vulncheck.com/advisories/foxit-pdf-reader-title-stack-buffer-overflow
Get alerted when CVE-2010-20010 or the next vulnerability affects your stack