What’s Vulnerable › Vulnerabilities
CVE-2010-2089
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-05-27 · updated 2026-06-16
- Weakness: CWE-787
Description
The audioop module in Python 2.7 and 3.2 does not verify the relationships between size arguments and byte string lengths, which allows context-dependent attackers to cause a denial of service (memory corruption and application crash) via crafted arguments, as demonstrated by a call to audioop.reverse with a one-byte string, a different vulnerability than CVE-2010-1634.
Affected products
- Python: from 2.5.0 before 2.5.6; from 2.6.0 before 2.6.6; from 3.1.0 before 3.1.3 — fixed in 2.5.6, 2.6.6, 3.1.3
How to fix
Upgrade to a fixed version: Python 2.5.6, 2.6.6, 3.1.3. Check the vendor advisory for mitigations.
References
- http://bugs.python.org/issue7673
- http://lists.apple.com/archives/Security-announce/2011//Oct/msg00003.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-June/042751.html
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40194
- http://secunia.com/advisories/42888
- http://secunia.com/advisories/43068
- http://secunia.com/advisories/50858
- http://secunia.com/advisories/51024
- http://secunia.com/advisories/51040
- http://secunia.com/advisories/51087
Get alerted when CVE-2010-2089 or the next vulnerability affects your stack