What’s Vulnerable › Vulnerabilities

CVE-2010-2179

Description

Cross-site scripting (XSS) vulnerability in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR before 2.0.2.12610, when Firefox or Chrome is used, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to URL parsing.

Affected products

How to fix

Upgrade to a fixed version: Adobe Air 2.0.2.12610; Adobe Flash Player 24.0.0.186 and earlier. 10.1.53.64, 9.0.277.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-2179 or the next vulnerability affects your stack