What’s Vulnerable › Vulnerabilities
CVE-2010-2250
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-07 · updated 2026-06-16
- Weakness: CWE-79
Description
Drupal 5.x and 6.x before 6.16 uses a user-supplied value in output during site installation which could allow an attacker to craft a URL and perform a cross-site scripting attack.
Affected products
- Drupal: from 5.0 before 5.22; from 6.0 before 6.16 — fixed in 5.22, 6.16
How to fix
Upgrade to a fixed version: Drupal 5.22, 6.16. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/02/12/8
- https://security-tracker.debian.org/tracker/CVE-2010-2250
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.openwall.com/lists/oss-security/2010/06/28/8
- http://www.openwall.com/lists/oss-security/2014/02/12/8
- https://security-tracker.debian.org/tracker/CVE-2010-2250
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
Get alerted when CVE-2010-2250 or the next vulnerability affects your stack