What’s Vulnerable › Vulnerabilities
CVE-2010-2266
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-06-15 · updated 2026-06-16
- Weakness: CWE-22
Description
nginx 0.8.36 allows remote attackers to cause a denial of service (crash) via certain encoded directory traversal sequences that trigger memory corruption, as demonstrated using the "%c0.%c0." sequence.
Affected products
- nginx: from 0.7.52 before 0.7.67; from 0.8.0 through 0.8.40 — fixed in 0.7.67
How to fix
Upgrade to a fixed version: nginx 0.7.67. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2010-2266 or the next vulnerability affects your stack