What’s Vulnerable › Vulnerabilities
CVE-2010-2300
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-06-15 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in the Element::normalizeAttributes function in dom/Element.cpp in WebCore in WebKit in Google Chrome before 5.0.375.70 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via vectors related to handlers for DOM mutation events, aka rdar problem 7948784. NOTE: this might overlap CVE-2010-1759.
Affected products
- Google Chrome: before 5.0.375.70 — fixed in 5.0.375.70
How to fix
Upgrade to a fixed version: Google Chrome 5.0.375.70. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=43315
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
- http://secunia.com/advisories/43068
- http://www.vupen.com/english/advisories/2011/0212
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11357
- http://code.google.com/p/chromium/issues/detail?id=43315
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
- http://secunia.com/advisories/43068
Get alerted when CVE-2010-2300 or the next vulnerability affects your stack