What’s Vulnerable › Vulnerabilities
CVE-2010-2301
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2010-06-15 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in editing/markup.cpp in WebCore in WebKit in Google Chrome before 5.0.375.70 allows remote attackers to inject arbitrary web script or HTML via vectors related to the node.innerHTML property of a TEXTAREA element. NOTE: this might overlap CVE-2010-1762.
Affected products
- Google Chrome: before 5.0.375.70 — fixed in 5.0.375.70
- Opensuse: 11.2, 11.3
- Suse Linux Enterprise Desktop: 10-sp3, 11-sp1
- SUSE Linux Enterprise: 10-sp3, 11-sp1
How to fix
Upgrade to a fixed version: Google Chrome 5.0.375.70. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=43902
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
- http://secunia.com/advisories/43068
- http://www.vupen.com/english/advisories/2011/0212
- https://bugs.webkit.org/show_bug.cgi?id=38922
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11861
- http://code.google.com/p/chromium/issues/detail?id=43902
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
Get alerted when CVE-2010-2301 or the next vulnerability affects your stack