What’s Vulnerable › Vulnerabilities
CVE-2010-2302
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-06-15 · updated 2026-06-16
- Weakness: CWE-416
Description
Use-after-free vulnerability in WebCore in WebKit in Google Chrome before 5.0.375.70 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via vectors involving remote fonts in conjunction with shadow DOM trees, aka rdar problem 8007953. NOTE: this might overlap CVE-2010-1771.
Affected products
- Google Chrome: before 5.0.375.70 — fixed in 5.0.375.70
- Opensuse: 11.2, 11.3
- Suse Linux Enterprise Desktop: 10-sp3, 11-sp1
- SUSE Linux Enterprise: 10-sp3, 11-sp1
How to fix
Upgrade to a fixed version: Google Chrome 5.0.375.70. Check the vendor advisory for mitigations.
References
- http://code.google.com/p/chromium/issues/detail?id=44740
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
- http://secunia.com/advisories/43068
- http://www.vupen.com/english/advisories/2011/0212
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11948
- http://code.google.com/p/chromium/issues/detail?id=44740
- http://googlechromereleases.blogspot.com/2010/06/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00006.html
- http://secunia.com/advisories/40072
- http://secunia.com/advisories/43068
Get alerted when CVE-2010-2302 or the next vulnerability affects your stack