What’s Vulnerable › Vulnerabilities
CVE-2010-2471
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-16
- Weakness: CWE-601
Description
Drupal versions 5.x and 6.x has open redirection
Affected products
- Debian Linux: 5.0
- Drupal: from 5.0 before 5.22; from 6.0 before 6.16 — fixed in 5.22, 6.16
How to fix
Upgrade to a fixed version: Drupal 5.22, 6.16. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/02/12/8
- https://access.redhat.com/security/cve/cve-2010-2471
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=592716
- https://security-tracker.debian.org/tracker/CVE-2010-2471
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.drupal.org/node/731710
- https://www.openwall.com/lists/oss-security/2010/06/28/8
- http://www.openwall.com/lists/oss-security/2014/02/12/8
- https://access.redhat.com/security/cve/cve-2010-2471
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=592716
Get alerted when CVE-2010-2471 or the next vulnerability affects your stack