What’s Vulnerable › Vulnerabilities
CVE-2010-2473
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-07 · updated 2026-06-16
- Weakness: CWE-20
Description
Drupal 6.x before 6.16 and 5.x before version 5.22 does not properly block users under certain circumstances. A user with an open session that was blocked could maintain their session on the Drupal site despite being blocked.
Affected products
- Drupal: from 5.0 before 5.22; from 6.0 before 6.16 — fixed in 5.22, 6.16
How to fix
Upgrade to a fixed version: Drupal 5.22, 6.16. Check the vendor advisory for mitigations.
References
- https://security-tracker.debian.org/tracker/CVE-2010-2473
- https://www.drupal.org/node/731710
- https://www.openwall.com/lists/oss-security/2010/06/28/8
- https://security-tracker.debian.org/tracker/CVE-2010-2473
- https://www.drupal.org/node/731710
- https://www.openwall.com/lists/oss-security/2010/06/28/8
Get alerted when CVE-2010-2473 or the next vulnerability affects your stack