What’s Vulnerable › Vulnerabilities
CVE-2010-2478
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-09-29 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the ethtool_get_rxnfc function in net/core/ethtool.c in the Linux kernel before 2.6.33.7 on 32-bit platforms allows local users to cause a denial of service or possibly have unspecified other impact via an ETHTOOL_GRXCLSRLALL ethtool command with a large info.rule_cnt value that triggers a buffer overflow, a different vulnerability than CVE-2010-3084.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04, 10.10
- Linux kernel: before 2.6.33.7 — fixed in 2.6.33.7
- SUSE Linux Enterprise Server 15 SP1: 11-sp1
- SUSE Linux Enterprise Server: 11-sp1
How to fix
Upgrade to a fixed version: Linux kernel 2.6.33.7. Check the vendor advisory for mitigations.
References
- http://article.gmane.org/gmane.linux.network/164869
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=db048b69037e7fa6a7d9e95a1271a50dc08ae233
- http://lists.opensuse.org/opensuse-security-announce/2010-09/msg00004.html
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.33.7
- http://www.openwall.com/lists/oss-security/2010/06/29/1
- http://www.openwall.com/lists/oss-security/2010/06/29/3
- http://www.openwall.com/lists/oss-security/2010/06/30/17
- http://www.securityfocus.com/bid/41223
- http://www.ubuntu.com/usn/USN-1000-1
- https://bugzilla.redhat.com/show_bug.cgi?id=608950
- http://article.gmane.org/gmane.linux.network/164869
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=db048b69037e7fa6a7d9e95a1271a50dc08ae233
Get alerted when CVE-2010-2478 or the next vulnerability affects your stack