What’s Vulnerable › Vulnerabilities
CVE-2010-2495
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-09-08 · updated 2026-06-16
- Weakness: CWE-476
Description
The pppol2tp_xmit function in drivers/net/pppol2tp.c in the L2TP implementation in the Linux kernel before 2.6.34 does not properly validate certain values associated with an interface, which allows attackers to cause a denial of service (NULL pointer dereference and OOPS) or possibly have unspecified other impact via vectors related to a routing change.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04, 10.10
- Linux kernel: before 2.6.34 — fixed in 2.6.34
- Suse Linux Enterprise Desktop: 11-sp1
- Suse Linux Enterprise High Availability Extension: 11-sp1
- SUSE Linux Enterprise: 11-sp1
How to fix
Upgrade to a fixed version: Linux kernel 2.6.34. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=3feec9095d12e311b7d4eb7fe7e5dfa75d4a72a5
- http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00000.html
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.34
- http://www.openwall.com/lists/oss-security/2010/06/23/3
- http://www.openwall.com/lists/oss-security/2010/07/04/2
- http://www.openwall.com/lists/oss-security/2010/07/04/3
- http://www.openwall.com/lists/oss-security/2010/07/06/11
- http://www.ubuntu.com/usn/USN-1000-1
- https://bugzilla.redhat.com/show_bug.cgi?id=607054
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=3feec9095d12e311b7d4eb7fe7e5dfa75d4a72a5
- http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00000.html
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.34
Get alerted when CVE-2010-2495 or the next vulnerability affects your stack