What’s Vulnerable › Vulnerabilities
CVE-2010-2527
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-08-19 · updated 2026-06-16
- Weakness: CWE-120
Description
Multiple buffer overflows in demo programs in FreeType before 2.4.0 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted font file.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04
- Debian Linux: 5.0
- FreeType: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: FreeType 2.4.0. Check the vendor advisory for mitigations.
References
- http://git.savannah.gnu.org/cgit/freetype/freetype2-demos.git/commit/?id=b995299b73ba4cd259f221f500d4e63095508bec
- http://lists.nongnu.org/archive/html/freetype/2010-07/msg00001.html
- http://marc.info/?l=oss-security&m=127912955808467&w=2
- http://savannah.nongnu.org/bugs/?30054
- http://secunia.com/advisories/48951
- http://securitytracker.com/id?1024266
- http://www.debian.org/security/2010/dsa-2070
- http://www.redhat.com/support/errata/RHSA-2010-0577.html
- http://www.redhat.com/support/errata/RHSA-2010-0578.html
- http://www.ubuntu.com/usn/USN-963-1
- https://bugzilla.redhat.com/show_bug.cgi?id=614557
- http://git.savannah.gnu.org/cgit/freetype/freetype2-demos.git/commit/?id=b995299b73ba4cd259f221f500d4e63095508bec
Get alerted when CVE-2010-2527 or the next vulnerability affects your stack