What’s Vulnerable › Vulnerabilities
CVE-2010-2941
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-11-05 · updated 2026-06-16
- Weakness: CWE-416
Description
ipp.c in cupsd in CUPS 1.4.4 and earlier does not properly allocate memory for attribute values with invalid string data types, which allows remote attackers to cause a denial of service (use-after-free and application crash) or possibly execute arbitrary code via a crafted IPP request.
Affected products
- cups: through 1.4.4
- macOS: before 10.5.8; from 10.6.0 through 10.6.4 — fixed in 10.5.8
- Apple Mac Os X Server: before 10.5.8; from 10.6.0 through 10.6.4 — fixed in 10.5.8
- Canonical Ubuntu Linux: 6.06, 8.04, 9.10, 10.04, 10.10
- Debian Linux: 5.0
- Fedoraproject Fedora: 12, 13, 14
- Opensuse: 11.1, 11.2, 11.3
- Red Hat Enterprise Linux: 5.0, 6.0
- RedHat Enterprise Linux Desktop: 5.0
- RedHat Enterprise Linux Server: 5.0
- RedHat Enterprise Linux Workstation: 5.0
- SUSE Linux Enterprise: 10.0-sp3, 11.0, 11.0-sp1
- SUSE Linux Enterprise Server: 9
How to fix
Upgrade to a fixed version: macOS 10.5.8; Apple Mac Os X Server 10.5.8. Check the vendor advisory for mitigations.
References
- http://blogs.sun.com/security/entry/multiple_vulnerabilities_in_mozilla_firefox
- http://lists.apple.com/archives/security-announce/2010//Nov/msg00000.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/050977.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051277.html
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051301.html
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00000.html
- http://rhn.redhat.com/errata/RHSA-2010-0811.html
- http://secunia.com/advisories/42287
- http://secunia.com/advisories/42867
- http://secunia.com/advisories/43521
- http://security.gentoo.org/glsa/glsa-201207-10.xml
- http://securitytracker.com/id?1024662
Get alerted when CVE-2010-2941 or the next vulnerability affects your stack