What’s Vulnerable › Vulnerabilities

CVE-2010-2959

Description

Integer overflow in net/can/bcm.c in the Controller Area Network (CAN) implementation in the Linux kernel before 2.6.27.53, 2.6.32.x before 2.6.32.21, 2.6.34.x before 2.6.34.6, and 2.6.35.x before 2.6.35.4 allows attackers to execute arbitrary code or cause a denial of service (system crash) via crafted CAN traffic.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 2.6.27.53, 2.6.32.21, 2.6.34.6, 2.6.35.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2010-2959 or the next vulnerability affects your stack