What’s Vulnerable › Vulnerabilities
CVE-2010-2962
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-11-26 · updated 2026-06-16
- Weakness: CWE-20
Description
drivers/gpu/drm/i915/i915_gem.c in the Graphics Execution Manager (GEM) in the Intel i915 driver in the Direct Rendering Manager (DRM) subsystem in the Linux kernel before 2.6.36 does not properly validate pointers to blocks of memory, which allows local users to write to arbitrary kernel memory locations, and consequently gain privileges, via crafted use of the ioctl interface, related to (1) pwrite and (2) pread operations.
Affected products
- Canonical Ubuntu Linux: 9.10, 10.04, 10.10
- Fedoraproject Fedora: 13
- Linux kernel: before 2.6.36 — fixed in 2.6.36
- Opensuse: 11.3
- SUSE Linux Enterprise Server 15 SP1: 11-sp1
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 11-sp1
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=ce9d419dbecc292cc3e06e8b1d6d123d3fa813a4
- http://lists.fedoraproject.org/pipermail/package-announce/2010-December/052513.html
- http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2010-10/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://secunia.com/advisories/42745
- http://secunia.com/advisories/42758
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.36
- http://www.redhat.com/support/errata/RHSA-2010-0842.html
- http://www.redhat.com/support/errata/RHSA-2010-0958.html
- http://www.securityfocus.com/bid/44067
- http://www.ubuntu.com/usn/USN-1041-1
Get alerted when CVE-2010-2962 or the next vulnerability affects your stack