What’s Vulnerable › Vulnerabilities
CVE-2010-3067
- Severity: medium (CVSS 4.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2010-09-21 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the do_io_submit function in fs/aio.c in the Linux kernel before 2.6.36-rc4-next-20100915 allows local users to cause a denial of service or possibly have unspecified other impact via crafted use of the io_submit system call.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 9.04, 9.10, 10.04, 10.10
- Debian Linux: 5.0
- Linux kernel: before 2.6.36; 2.6.36, 2.6.36-rc1, 2.6.36-rc2, 2.6.36-rc3 — fixed in 2.6.36
- Opensuse: 11.2, 11.3
- SUSE Linux Enterprise Server 15 SP1: 10-sp3
- SUSE Linux Enterprise Real Time Extension: 11-sp1
- SUSE Linux Enterprise Server: 9, 10-sp3
- SUSE Linux Enterprise Software Development Kit: 10-sp3
How to fix
Upgrade to a fixed version: Linux kernel 2.6.36. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=75e1c70fc31490ef8a373ea2a4bea2524099b478
- http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-01/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-02/msg00002.html
- http://secunia.com/advisories/42778
- http://secunia.com/advisories/42801
- http://secunia.com/advisories/42890
- http://secunia.com/advisories/43291
- http://secunia.com/advisories/46397
- http://www.debian.org/security/2010/dsa-2126
Get alerted when CVE-2010-3067 or the next vulnerability affects your stack